ThatQuiz Бібліотека тестів Виконайте цей тест зараз
Роботи. - тест
Поширений: Шевченко
  • 1. Роботи - це машини, призначені для автоматичного виконання завдань, часто з точністю та ефективністю. Вони бувають різних форм і розмірів, від промислових роботів, що використовуються на виробництві, до людиноподібних роботів, які можуть допомагати в домашніх справах. З розвитком технологій, таких як штучний інтелект і машинне навчання, роботи стають все більш досконалими, здатними навчатися і адаптуватися до нових ситуацій. Хоча дехто може побоюватися, що роботи замінять людську працю, вони також мають потенціал покращити наше життя, беручи на себе небезпечні або повторювані завдання, звільняючи людей, щоб зосередитися на більш творчих починаннях.

    Що означає штучний інтелект по відношенню до роботів?
A) Автоматизована інтеграція
B) Розширений інтерфейс
C) Аналіз та розслідування
D) Штучний інтелект
  • 2. Який виробник роботів відомий завдяки створенню людиноподібного робота "ASIMO"?
A) Sony
B) Toyota
C) LG
D) Хонда
  • 3. Як звуть робота-компаньйона у фільмі "Волл-І"?
A) БОЛТ
B) C-3PO.
C) R2-D2.
D) ЄВА
  • 4. Який відомий робот відомий своєю крилатою фразою "Небезпека, Вілл Робінсон!"?
A) Оптимус Прайм
B) C-3PO.
C) ВОЛЛ-І
D) Робот B-9
  • 5. Як називалася система штучного інтелекту у фільмі "2001: Космічна одіссея"?
A) HAL 9000
B) Альтрон.
C) Скайнет.
D) Мамо.
  • 6. Яка робототехнічна компанія відома завдяки створенню модульної робототехнічної системи "Бакстер"?
A) iRobot
B) Blue Origin
C) Переосмислити робототехніку
D) Boston Dynamics
  • 7. Як називалася знаменита збірка науково-фантастичних оповідань Айзека Азімова, в якій були представлені три закони робототехніки?
A) Нейромант.
B) Снігова катастрофа
C) Я, Робот.
D) Чи мріють андроїди про електричних овець?
  • 8. Як називається здатність робота вчитися на власному досвіді та покращувати продуктивність з часом?
A) Соціальні мережі
B) Бездротовий зв'язок
C) Машинне навчання
D) Віртуальна реальність
  • 9. Якого відомого робота часто характеризують як такого, що хоче "винищити" людей?
A) R2-D2.
B) Далек.
C) Бендере.
D) Джонні 5
  • 10. Яка країна є світовим рекордсменом за кількістю роботів на 10 000 виробничих робітників?
A) Південна Корея
B) Японія
C) Китай
D) Німеччина
  • 11. Як називається процес програмування робота для виконання певного завдання шляхом демонстрації завдання роботу?
A) Програмування за допомогою демонстрації
B) Глибоке навчання з підкріпленням
C) Штучні нейронні мережі
D) Генетичні алгоритми
  • 12. Як називається здатність робота імітувати людські дії або вирази обличчя?
A) Артикуляція
B) Алгоритм
C) Автоматизація
D) Антропоморфізм
  • 13. Як зазвичай називають протокол виключення роботів?
A) crawler-rules.json
B) robots.txt
C) sitemap.xml
D) meta-теги.html
  • 14. Хто запропонував стандарт для файлу robots.txt у 1994 році?
A) Чарльз Стросс
B) Вінт Серф
C) Мартін Костер
D) Тім Бернерс-Лі
  • 15. Якою була первинна назва файлу robots.txt, коли його було запропоновано?
A) RobotsNotWanted.txt
B) CrawlerExclusion.txt
C) WebBotRules.txt
D) PageAccessControl.txt
  • 16. У якому році компанія Google запропонувала протокол виключення роботів (Robots Exclusion Protocol) як офіційний стандарт?
A) 2022
B) 1998
C) 2019
D) 2005
  • 17. Яка основна мета файлу robots.txt?
A) Вказати, які розділи веб-сайту дозволено відвідувати веб-скаутерам.
B) Відображати рекламу.
C) Підвищити безпеку веб-сайту за допомогою шифрування.
D) Зберігати облікові дані користувачів для входу.
  • 18. Де повинен знаходитися файл robots.txt на веб-сайті?
A) У кореневій директорії веб-сайту.
B) У файлах конфігурації сервера.
C) Всередині кожної директорії, до якої він застосовується.
D) У кеші браузера користувача.
  • 19. Що відбувається, якщо на веб-сайті відсутній файл robots.txt?
A) Веб-боти вважають, що немає обмежень на обхід та індексацію всього сайту.
B) Усі веб-сторінки автоматично індексуються.
C) Веб-сайт блокується пошуковими системами.
D) Сервер повертає помилку 404.
  • 20. Що робити, якщо веб-сайт має кілька піддоменів, і для кожного з них потрібен власний файл robots.txt?
A) Кожен піддомен повинен мати власний файл robots.txt.
B) Ігноруйте файл robots.txt для піддоменів.
C) Використовуйте один і той же файл robots.txt для всіх піддоменів.
D) Розмістіть один файл robots.txt у кореневій директорії.
  • 21. Чи можуть посилання на сторінки, перелічені у файлі robots.txt, з'являтися в результатах пошуку?
A) Так, якщо на них є посилання з іншої сторінки, яку сканує пошукова система.
B) Ні, вони ніколи не з'являться в результатах пошуку.
C) Вони з'являються лише в тому випадку, якщо файл robots.txt відсутній.
D) Тільки якщо власник сайту схвалить це вручну.
  • 22. Якою була основна проблема, пов'язана з перевантаженням серверів, коли вперше було впроваджено файл robots.txt?
A) Складні запити до бази даних.
B) Високе споживання трафіку через потокове відео.
C) Інтернет був достатньо малим, щоб підтримувати повний список усіх ботів.
D) Завантаження великих файлів користувачами.
  • 23. Який формат має містити файл robots.txt?
A) Двійковий код
B) Спеціальний текстовий формат
C) Об'єкти JSON
D) HTML-теги
  • 24. Яка організація опублікувала протокол заборони роботів (Robots Exclusion Protocol) як офіційний стандарт у вересні 2022 року?
A) Консорціум World Wide Web (World Wide Web Consortium, W3C)
B) Міжнародна організація зі стандартизації (International Organization for Standardization, ISO)
C) Інститут інженерів електротехніки та електроніки (Institute of Electrical and Electronics Engineers, IEEE)
D) Група з розробки інтернет-технологій (Internet Engineering Task Force, IETF)
  • 25. Які дії, що не рекомендуються організаціями, що встановлюють стандарти, при роботі зі шкідливими ботами, використовуючи файл robots.txt?
A) Використання міжмережевих екранів (файрволів).
B) Впровадження систем CAPTCHA.
C) Захист шляхом приховування інформації.
D) Використання шифрування.
  • 26. Яка мета використання файлу robots.txt у поєднанні з картами сайту?
A) Для збільшення швидкості завантаження сторінок.
B) Для покращення візуального дизайну.
C) Для управління тим, які частини веб-сайту будуть проіндексовані та проскануті.
D) Для шифрування передачі даних.
  • 27. Який номер RFC для запропонованого стандарту, опублікованого у вересні 2022 року?
A) RFC 2616
B) RFC 7230
C) RFC 3986
D) RFC 9309
  • 28. Яка потенційна причина використання файлу robots.txt на веб-сайті?
A) Щоб запобігти відображенню певного контенту, який може бути оманливим або нерелевантним, у результатах пошуку.
B) Щоб покращити апаратне забезпечення сервера.
C) Щоб покращити відтворення мультимедійного контенту.
D) Щоб збільшити кількість відвідувачів.
  • 29. Яке значення має файл robots.txt у юридичних справах, що стосуються ботів?
A) Суди вимагають створення файлів robots.txt для всіх веб-сайтів.
B) Судові справи показали, що файл robots.txt не має значення для роботи ботів.
C) Він використовувався як підстава для судових позовів проти операторів ботів, які не дотримуються правил.
D) Суди завжди ігнорують файл robots.txt у таких випадках.
  • 30. Які пошукові системи дотримуються стандарту robots.txt?
A) Ask, AOL, Baidu, Bing, DuckDuckGo, Kagi, Google, Yahoo!, Yandex
B) Facebook, Twitter, Instagram
C) LinkedIn, WhatsApp, Telegram
D) Amazon, eBay, Alibaba
  • 31. У 2023 році, скільки з тисячі найпопулярніших веб-сайтів заблокували бота GPT від OpenAI?
A) 500
B) 100
C) 50
D) 306
  • 32. Які компанії брали участь у запуску RSL?
A) Amazon, eBay, Alibaba
B) Google, Facebook, Twitter
C) LinkedIn, WhatsApp, Telegram
D) Medium, Reddit, Yahoo
  • 33. Який пошуковий робот інтерпретує параметр 'crawl-delay' як розмір часового інтервалу, протягом якого він буде отримувати доступ до сайту лише один раз?
A) Усі пошукові роботи
B) Yandex
C) Googlebot
D) BingBot
  • 34. Який максимальний розмір файлу robots.txt згідно з обмеженнями Google?
A) 256 кілобайт
B) 500 кібібайт (512000 байт)
C) Без обмежень
D) 1 мегабайт
  • 35. Яка директива, запроваджена компанією Cloudflare, визначає прийнятну поведінку для веб-сканувань?
A) Crawl-delay
B) Content-Signal
C) Sitemap
D) Disallow
  • 36. Який з цих пунктів не є частиною стандартного протоколу заборони для роботів (Robots Exclusion Protocol)?
A) Sitemap
B) Allow
C) Crawl-delay
D) Disallow
Створено з That Quiz — де тест з математики виконуються одним клацанням миші.